What’s New in ShipWeight 10.0
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New Main Window

ShipWeight 10.0 comes with a new main window to improve user friendliness and increase flexibility

on the work breakdown structure.
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Picture 1: The new main window

The main change in the new main window is that the grids and the weight group hierarchy have been

merged. The result is a more intuitive way of navigating in the weight group hierarchy and also the

number of weight groups on the same level of the structure is no longer restricted by the grids —

there is no limitation to this anymore.

Icons are used in the new main window to inform

about the origin of the weight group summary. A

grid icon indicates that the weight groups is a
summary of weight items for that very weight group,

while a sigma symbol indicates that the value is a

summation of subgroups — not items. Finally, a graph

icon will indicate that the value is estimated by

‘— HJH1.5 - Upper area

— &) H2 - Poop
— —EJ H3 - Superstructure
— - EJ) H4 - Deckhouses

— - EJ H5 - Forecastle

— EJ H6 - Keel

parametric formula. Grid and graph icons are also clickable and will open of the item dialog and

graph dialog accordingly.
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In the right part of the main window, several information windows
are shown. This shows project, parameter and code information.
This area can be hidden all in one by clicking the “Hide info >>"
button; in case maximum space is required for the weight group
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In addition to display the values for parameters, the codes window will also show a summary of the

weight per code. This can potentially slow down speed on very large project and so there is an option

in the Option dialog to turn off this summation.
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Playground Area

The new Playground Area in ShipWeight provides a sandbox environment where weight data can be
changed, added or deleted without affecting the weight data in the project. Only when the data is
transferred from the playground area and back into the project, changes are accounted in
calculations and output. The playground area can be used in two modes; with and without
“Worksets”. Data in the Playground Area is a copy of the data in the main area.

The graphical user interface for the Playground Area is similar to the Item Dialog. To distinguish and
clearly mark the Playground Area from the normal Item Dialog, a color by choice of the user can be
selected in the Option dialog.

rOptions lm [ e v =y )

e o Setong looh Yiew Wndow
.4 PH O ARE ! TRLE %R ey - B S - -

Advanced [Log | Report [ em | Estimation [ Workset| Playground | <>

Background color:  RGB(0,191,63) -Q

1,006 17356.000] 17350,000]
1,000 1681.000 16410.000
| 1000 14590.000) 14590000/
| 1000 14000,000, 14080.000]

— - .

Playground Area may be opened by selecting “Item Playground...” on the “Weight Groups” menu in
the main window, or by selecting the Playground Area button in the toolbar.

Using the Playground Area without Worksets

If the Playground Area is used without Worksets, weight items may be transferred from the database
to the playground environment by marking the items to be copied and selecting “Copy to
Playground” from the “Edit” menu in the Item dialog.

Items in the playground area, which has been added to this area, or copied in from the project data,
may be transferred back to the project by marking the items to be transferred and select “Move back
to Iltem” from the “Edit” menu while in the Item dialog in playground mode.

Working like this is quite similar as to copying items to and from Excel or other spreadsheet tools.
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Using Worksets with the Playground Area
When Worksets are used in ShipWeight, this set up a stricter and more controlled way of transferring
items between the Playground Area and the project.

To start working with Worksets a custom code needs to be defined (Code Definition dialog) to hold
the identifier of the Workset. This custom code must be of the type “Listbox” and list selection code
must be added, each one intended to group weight items to be checked in and out of the Playground
area.

& | Code Definition

€01 - Section code
C02 - Area code

C03 - Module code
C04 - Function code
€05 - Discipline code
C06 - Phase code

CO7 - Status code
CO0B - Installation code
€09 - Comment

C10 - Assembly

w1
w2
w3
W4
W5

wWe Ll K] I [ ‘_—]
J

Once the custom codes have been defined, Worksets must be enabled and proper settings for the
Playground area must be defined in the Options dialog. In the tabsheet named “Worksets” in the
Options dialog, Worksets are enabled by checking the checkbox “Use worlsets”, followed by selecting
the custom codes that was set up to identify the Worksets. This is done in the droplist to the right of
the checkbox. Other settings includes selecting codes to be tracked for the Workset, titles for
comment fields and setting up margins to be used to carry net changes when a Workset is checked
back into the project.

Oplinrf l_ﬁ ( Margins ﬂ

Margin ID Description Weight [t] VCG [m] LEG [m]
ig Build margin 80.000 0.000 0.000
Comment 1 label: Design margin 150.000 5.000 0.000

Comment 2 label: Checker comment GFM margin 50,000 0.000 0.000

Comment 3 label: Remark - 0.000 0.000 0.000
Code fields: Margins: °
V| C01 - Section code ~ || Margin ID Description {

02 - Area code

_ || Build margin
| C03 - Module code S| pesign margin
| C04 - Function code
€05 - Discipline code Erm e
€06 - Phase code
|07 - Status code - || i »
[ import | oK ] [ concel | ¢ ] ’

i)

print_|

Picture 6: Setting Workset options and defining margins

The margins can be freely defined; both when it comes to number of margins, names and values.
Click the browse button (...) to open the margin definition dialog.
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Checking a Workset with Weight Items out to the Playground

When the Worksets have been set up and defined, weight items tagged to the various Workset codes
can be checked out and into the Playground Area. The checking of items in and out of this area is
controlled in a separate dialog called “Worksets”. You can access this dialog by selecting
“Worksets...” on the “Items” menu in the main window. The “Worksets” dialog will show a list of the
defined codes for the Workset and you can check weight items tagged to this code by selecting the
code and click the “Check out” button.

The Workset dialog gives an overview of the status and history of the items that have been checked
out or in of the Playground Area. Columns give time and user responsible for the operations
belonging to the Workset such as checking, reviewing, rejecting and/or approving.

— . _ _ _ _ _ - - _ e
B Worksets = __I';I'_'@
Workset Check Out Per... Calculate Pers... Last Change D... Last Change P... Review Date Review Person Reject Date Reject Person  Approve Date  Approve Person
Wil -
4 7011.04.26... Runar Runar 2011.04.26 1... Runar 2011.04.26 1... Runar 2011.04.26 1... Runar

| w2 -
I # 2011.03.16... Runar Runar 2011.03.16 1... Runar 2011.03.16 1... Runar 2011.03.16 1... Runar
| w3 -
' #2011.04.26... Runar
| W4 -
[ ws-
| 4 2011.04.18... Runar Runar 2011.04.18 1... Runar 2011.04.18 1... Runar 2011.04.18 1... Runar
| * 2011.04.18... Runar Runar 2011.04.18 1... Runar 2011.04.26 2... Runar
| we-
| #2011.04.26... Unregisteret ...
|
|
{1 '
|
: [_Revew ] ot Gose

Picture 7: The Workset dialog gives an overview of status

The status and icons in the Workset dialog can be as follows:

e Red arrow means the Workset has been checked out

e Red arrow with exclamation mark means the Workset has been reviewed and rejected

e Red arrow with plus sign means a new Workset, previously not existing in the main data, has
been imported or added manually in the Playground Area

e Green arrow means the Workset has been checked in and approved

Working with Checked Out Items in the Playground Area

The weight items that have been checked out through the Workset dialog can be opened in the
Playground area and changes can be made to the Workset. Weight items can be changed, added
and/or deleted. It is important to tag new items added with the correct Workset code to make sure
it is accounted for when the Workset is up for review.
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Reviewing Worksets (Rejecting or Approving Worksets)

When a job on a Workset is finished, the change details and net change may be reviewed and the
Workset may be rejected or approved. From the Workset dialog, the Workset can be reviewed by
selecting the Workset marked as checked out and click the button “Review” this will open up a
review dialog.

- r
7 Workset Review, Approve & Check In L =X
Workset: W1 Calcutator comment
Rol User D Date |
Checled Out Runar 2011.04.26 22:34:52
Calculated Runar Checker comment
Last changed Runar 2011,04.26 22:35:59
Revewed
Rejected Remark
Approved
Code Value Source Wieight VCG LCG TCG VCG-m «
€01 - Section code Database 33.014 14.488 29.697 2.025 +13
€02 - Ares code Workset 38238 1207 27.538 1.205 44
€03 - Module code M1 Change 5224 =177 <2158 -0.820
€14 - Function code &' Build margin - B0.000 0.000 0,000 0.000
Busld margin - Change B8.884 “1.771 2.158 -0.820
Busld marain - Remaining -8.884 -1.771 2158 -0.820 E
f I
waLgrp. Ttem no Description Weight VCG LG TG VCG-mom LCG-mom TCG-mom
EL10.3 62 Test 1.000 0.000 0.000 0.000 0.000 0.000 0.000
EL10.2 62 Test 2000 0.000 0.000 0.000 20.000 20.000 20,000
®EL10.3 62A Test 2.000 0.000 0.000 0.000 0.000 0.000 0.000
EL.10.6 36 Test 1.234 0.000 0.000 0.000 17.276 0.000 0.000
EL10.1 10 FW cargo pump 1-2 1470 0.000 0.000 0,000 B.673 27.195 -3.381
®ELS 12 Falfinger Crane -3.880 10.800 =0.200 10.000 41.904 0.776 -38.800
®EL4 12 Test -0.000 0.000 0.000 0.000 -0.000 -0.000 -0.000
EL10.1 § FO cargo pump 1-2 1.400 0.000 0.000 0,000 3.520 24640 1.400
Beview 0K Rejed |Approve & Check In| V] Shaw details Close

Picture 8: The Review dialog

The upper left area of the review dialog contains information about the current Workset that is up
for review. This includes information about who checked it out and when it was checked out, as well
as whom and when changes last was made to the Workset. Further, information is displayed for
codes belonging to the items in the Workset as selected for in the Options dialog.

The upper right part of the dialog gives the opportunity to add comments (titles are defined in the
Options dialog) to be saved in the Workset dialog along with values for the net changes. Further in
this area, information about the net change, and selection of the margin for which the net change
will be deducted from is made. All of this information will be stored in the Workset dialog for future
reporting when/if the Workset is approved and checked back in.

The lower part of the dialog shows the details of the changes that have been made to the Workset. If
a weight item has been changed in the Playground Area, the net change for the item will be shown in
the lower area. A checkbox “Show details” is available to enable or disable the detailed information.
The disabling of the detailed information will prevent slow performance of the dialog in case of a
very large number of changes in the Workset.

Colors in front of each change line indicate the type of change. Green means an added item; red
means a removed item while orange means a changed item. Once the details have been reviewed,
the user has the option to:

e Reject the Workset — in which case the items will not be checked back into the main data
e Review the Workset OK —in which case the change is reviewed OK but not checked back
e Approve and Check the Workset back into the main data
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Running a Report of the Net Changes

When the Review dialog is closed, actions taken are this dialog is

logged in the Workset dialog. The Workset dialog has a print button

that will produce a simple report of all net changes that has been

handled through Worksets.

User Permission Settings for Playground Area
A new branch in the “Permission” tab-sheet in the permission setting

dialog has been added to control access to the Playground Area. This

makes it possible to set up user groups that are only allowed to access

the Playground Area. The permission settings works similar as for the

Item dialog when run in normal mode.

Renaming Labels for VCG, LCG and TCG
The labels for center of gravity position, VCG LCG and TCG may be

renamed in the Options dialog. This will affect the label for center of

gravity in the main window, the item dialog and standard (embedded

reports).

Project Statistics

The Project menu in ShipWeight main window has a selection called

“Statistics”. This dialog will gather information about the projects on

the server, such as number of items, total weight, etc. The dialog may

-
B User Group Test’

Members | Permissons | weight groups | Codes
Permissions:
#1 [wytinfo
Projectinfo
Setting
Estimate
7| Playground
v Read
o Edit
¥ MultipleEdit
| Output
o Import/Export

—
Options

Genaral| Decimals | Quantay | Advanced [Log | Report | em | Estime * |

Weight:  VOG: LOG: TCG:
wetan: 3 vl 2 w1z w2 =
~min: 0 w2 =
= (] - v.

0
2 0

3 =l 3 = 3 = |3 -
3 3

-
Title:

oK | | Goncel

use some time to open up, depending on the number of projects and size of projects. The dialog also

has an “Open Project” button for convenient opening of a project selected from this dialog.

r

B | Project Statistics
Server: [RUNAR-PCIRAA

Project

4 SWOD_Demo
|—BAS_aAH03
|—BaAS_aHO4
I Statoll
sac
|—BAS_Estimate
BAS_Revl
|—BAS_Rev2
|—BAS_Rev3
|—BAS_Revd
Faer
l—pvT2
1. RT3

Print

| Open Project |

Wat.grps.

&

bPboooooowololoo

Items

oo o

98
98
100
619

619
A10

Codetypes

8
8
1
1
8
8
8
8
8
3
4
A

Total Wat.

3466.239
3466.239

0.000

0.000
3 620.686
2949.433
3192.491
3 466,239
3641.577
4 403.790

4 403.790
A 403 700

Total z

6.850
6.850

0.000

0.000
6.809
6.276
6.596
6.850
7.008
9.069

9.069
anaa

[EE] )

-

Total x Totalt y -
0.000 = |
0.000
0.000!
0.000
0.000
0.000
0.000
0.000
0.051
-0.701
-0.701

<0701

38.597
38.597
_0.000

0.000
36.410
35.723
39.245
38.597
38.343
38.293

38.293
N I0%

8|Page




Changing Sort Order and Icons in the WBS

Sort order and Icons in the main work breakdown structure can be set. In ShipWeight main window,
in the dialog opened from menu “Databases->Administrator->Wgt Grp definition...” you will find 2
columns “sSort” and “slcon” for this purpose.

These can be used to override the normal sorting. In example, 3 subgroups can be sorted by typing
1, 2, 3 in the sSort column to specify the order for these. Further you can use numbers 0 through 6

to specify icon type. See sample picture below where order has been rearranged for group A1-A3
and new icons have been given.

You must restart ShipWeight for the changes to take effect.

HOUSLON | 1es1)

Weight Groups Wight [1] S, dev.[%] VG [m] Suldec[%]  LCG [m] Sud . %] TCG [m] St Lower .. Upper...
— ISP - Desplacemant 200 1 10.00 0o 167 05e 000
R DR - Remsnder displacement 01 10.00 (1] 167 0o 000
D - Deadweight
o A - Passanger, crew B owese supply
A A3 - Owmer supply f
o A2 - Crew ' Edit Weight Groups =
Al - Fassangers
- cange vePwhon. sPostiD sPosthame |sPostover [sSort | sicon
" F - Fuels and hibricants W Dt i B [ — ]
o L - Licuids 3 gases 51 A Passenger, crew & owear Supply m [Paisengers  |A 2 |0
o P - Frovision and stores 5 C Carge 2 Crew A 2 1
o LW - Lightshp £ F Fusls and lubeicants t t t
& Temg - Temporary ¥ L Liguids and gases LAY jowmer supply 1A 1 2
§ P Provinon nd fores = {Cargo oW IE]
F LW Lighaship | [C1 Hod carge |C 4
Temp Temporary ez |Deckcargo (€ 5
DisP |Deplacerment 1
lor |Remandes di_. [pisp
W Deadweght _|DISP
e [S——— Y
Chirter

The numbers and corresponding icons are:

No icon
Equipment icon
Deadweight icon
Hull icon
Machinery icon
Remainder icon

ok wnN PO

Vessel icon
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Changes to the Standard/Embedded Reports

The report setup dialog (menu: Project->Report Setup...) has a new design and has a work

breakdown tree where selections can be made on which weight groups should be included or not in

these weight reports. When the reports are run, the filter dialog has now extended capabilities for

filtering; the general filter dialog has been added on a separate tab-sheet in the report filter screen,
and is opened by the browse button.

Report Setup |9 Report Filter u

Wagt.grp. ; = —

) | 5{¥/|DISF - Displacement - Simple | Advanced
" |comment | |SEI code 7]0R - Remainder displacement (=] [_PJ
"lsum Ttems (#/0W - Deadweight
: =HV]Lw - ughtship .
VCG VR - Remainder Ttem filter: i Q
"iicc' % [V|€ - Equipment
|VCG_min {1k - Hul
VCG_max + v |M - Machinery
LCG_min = V1T - Topside
LCG_max W/|TR - Remainder Topside
TCG_min =1 1¥T1 - Crude Oil System -
TCG_max L_Lyn o o
| 4 Ll | 2
Code type Report values Parameter sort
I' | co1  Section code - AN (@) Unit

["]co2  Area code = 19/ pefined (L) Area

Bilcos ~woduie code | " Lowest Ogject

|1 co4  Function code ’ 0K | l Cancel

1ens _ Riscinling code ) l oK | [ Cancel :
ecide which e

2ight reports

Parameters can be Grouped by User
The new parameter dialog allows for the user to label and group important parameters for the

project(s) by own choice.

® Parameters
Ptrm] Main Paromaeters| Test |

* Parameter
My Group
Area HE cabins [m2]
Area SES-skirt [m2]
Area bottom plating, cargo-...
Area battom pl., engine-are...

Value  Std.dev.[%]

AL

5]

Ll

Parent ID
Regstraton Person 5t
Regevaton Date 27

Main Vessel Type:

zowe

Graghics File

B Parameter View Setting

= My Group
Area HC cabins [m2]
Ares SES-skirt [m2]
#Area bottom plating, cargo-area [m2]
Area bottom pl,, engine-area [m2]

Add View
Add Group

Delete

Parameter

(i

Accomodation material

Adjusted blockcoefficient (-]

Aft thruster type

Aluminium in superstructure [%]
Area (total) superstricture [m2]
Area HC cabins [m2]

Area SES-skirt [m2]

Area accomodation, galley & aundry |
Area aft bulkh,, forecastle [m2]

Area air seating [m2]

Area battom pl., engine-area [m2]
Area battom plating, cargo-area [m2]
Area battom, afterbody [m2]

3T ] "

[ concel
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In the Parameter dialog, right clicking will give a submenu with an option “Parameter View
Settings...” which will pop up a dialog that lets the user define new tab-sheets and groups in the
parameter dialog. Right clicking in the Parameter View Settings... window will give options for
creating the views (tab-sheets) and groups. Parameters are added to the groups by dragging and
dropping from the list to the right. Right clicking in the parameter list will give a search function for
searching the parameter to be picked in the list.

Improved Data File Import Dialog (Easylmport)

The Data File Import dialog (menu: Project->Import->Data File...) now has an extra layer called
Easylmport which is designed to provide a wizard-like user interface to guide the user through setting
up and carry out the import step by step.

First step is to browse and select the spreadsheet file (the Data File import dialog now supports
import of XLSX files in addition to XLS files.).

Once the Excel file has been selected, a preview of the sheets included in the file will be shown. Next
step is to select the sheet to import.

When a sheet is selected, the import dialog will try to guess the mapping between the columns in the
spreadsheet and ShipWeight fields. Columns where mapping have been found automatically will get
a green color and the mapping will be shown in the list below. If this mapping is wrong, you can
deselect the column either in the sheet preview or in the list of linked columns.
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To manually add columns not automatically mapped, click on the column either in the preview sheet
or in the column list and select the corresponding ShipWeight field from the ShipWeight list

& Shipweight Exsyimport = E
[Basctart | impon
Biowsg T
Zatart Staatls | Sheetts | Shaetd
Map columes WGy Descrigh MoHt Foctor  Leng®h  With UritWesght VOB LCG. = LCG mn  LCG max
o ham CEEEE HacmE. 1 1 1 1 & (1] “7 13 s 474
y 141 el 1 1 1 i £ 128 ary 46 a8y a
111 HamwE 1 1 ] 1 T w7 ns ] ;s ‘s
111 Hwmen. 1 1 1 1 13 108 23 s i) iy
111 HahenC. 1 1 1 i) i ) 188 £ (1] ™ w
111 HmhmR. 1 1 1 1 00 (1] i ) 37 a3
111 M 1 1 1 1 i) " e (1] i3 i
112 HmhmE 1 1 1 1 £ L} 457 63 “ i
1101 Focwmn. 1 1 1 1 1420 28 178 1 i e
1101 Peamap. 1 1 1 1 . 1) e 23 it i %)
i 14 Cagarad 1 1 1 1 9 109 ua () T4 "3
15 | PallngerC 1 1 1 il (30 08 a2 i) 2 i
18 Seaea 1 1 1 1 s 7 au 57 a5 s
15 | Seeacecra 1 1 1 1 (9680 L a4 AT " e
Harizontal scrofba
£ forere
i FSian| .
. Wotm WD <-> WG
Bemiio Description <-> Description
Cuscrgton Mo <> Mot
it el Length <> Lencth
- ,
bl wdth <-> Widkh
Factr Uneeght <-> Unaiveight
Lengt VG <-> VG
Wi TOG -3 TCE
[l e
| Eesitia o LC_min <=3 LEG_min
Tutorial sty LCG LCG_max <> LCG_max
TG
Shawt VLG
Shoat1s G
AR LCGme
i LCG, max b mport
11112 mappod
Add rare bk
P ——

While a green column indicates a mapped column, a white column indicates an unmapped column
and a pink column is a selected but not yet mapped column.

An import can be run directly from this tabsheet (either to main database or to Playground area), or
the mappings and settings can be transferred to the normal data file import for more advanced
settings and checking.
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